服务项目
PCB抄板
PCB设计
芯片解密
样机制作
客服电话

PCB抄板部

0755-83676369,83035701

PCB设计部

0755-83676323,83676200

芯片解密部

0755-83662100,83662911

样机制作部

0755-83676369,82815425

技术支持 当前位置:上海致远科技有限公司 >> 技术支持 >> 深圳pcb抄板教你PCB设计软件坐标数据导出方法

深圳pcb抄板教你PCB设计软件坐标数据导出方法

  目前市场上 PCB设计软件众多,如 Altium 公司的 Protel 和 P-cad、Mentor 公司的 Powerpcb/Pads 和 Mentor Expedition、Cadence 公司的 Allegro 和 Orcad、日本 Zuken 公司的 Cadstar 和 CR-5000 等等,尤其是Protel、Pads 和 Allegro 三种 PCB 设计软件,几乎占据中国 PCB 设计软件市场 80%以上的份额,换句话说,如果掌握了这三种 PCB 设计软件的坐标数据导出方法,基本上就可以应对大多数新产品的挑战了,这对于承接大量外协产品的 EMS 工厂尤其重要。但问题是现在有很多工艺技术人员,特别是刚刚从事 SMT 行业的,并不掌握 PCB 设计软件坐标数据的导出方法,也就无法将 CAD 坐标数据转换为贴片程序,依然停留在利用贴片设备摄像头一个个在电路板上找元件坐标数据的原始贴片程序编辑方法上,这严重制约了生产效率和质量的提升。本文将详细介绍所有常见 PCB 设计软件坐标数据的导出方法及步骤,以给从事相关工作的工艺技术人员提供参考。笔者总结的坐标数据导出方法 有三种:
1)利用 PCB 设计软件自身功能导出;
2)利用专门 CAM 软件导出;
3)将一种不常见的 PCB 文件格式转换为另外一种常见格式 PCB 文件后再导出。
具体采用何种方法要根据具体情况而定,不能一概而论,本文将逐一介绍这几种方法。
2    利用PCB设计软件自身功能导出坐标数据
这是最常见的坐标数据导出方法,大多数工厂都采用这种方法获取元件坐标数据,步骤大致可以分为三步:
1)单位切换;
2)设置坐标原点;
3)坐标导出。
下面将分别介绍一些常见 PCB 设计软件坐标数据的导出方法。
2.1   PADS
PADS 软件是 Mentor 公司出品的面向中低端用户的一款优秀电路板设计软件,目前最新版本号是 2007,PADS 软件导出坐标文件步骤如下:
1)用 PADS 打开 PCB 文件。
2)切换公制单位。因为贴片机的单位是 mm,有些图形是以 mil 作单位,所以要切换成公制单位。具体操作过程如下:选择菜单“Setup→Preference”,在 Global 选项卡中 Design Unit 栏中选择 Metric,即切换为公制单位。
3)设定坐标原点。选择菜单“Setup→Set Origin”,用鼠标在 PCB 上选定恰当的位置并确定为新的坐标原点,一般选择 PCB 左下角。
4)输出坐标数据。选择菜单“File→CAM”,弹出如图 1 所示界面,在 Side 栏中选择 PCB 顶层或底层(Top or Bottom),Parts 栏中选择 SMT,Output 中选择输出贴片机格式, 这里选择 Dynapert Promann,然后点击“Run”按钮,在弹出的提示文件存盘路径的对话框 中点击确认键,坐标数据导出。
图 1   PADS 坐标数据输出
2.2   Protel
Protel 软件是最早进入中国板级设计市场的 PCB 设计软件,在中国拥有众多的用户,影响力巨大,目前最新版本号是 AD6.9,本文以 Protel 99 软件为例介绍坐标文件导出方法, 步骤如下:
1)用 Protel99 软件打开 PCB 文件。
2)设定原点。选择菜单“Edit →Origin → Set”,设定坐标原点。
3)导出坐标数据。选择菜单“File→Cam Manager…”,出现输出数据向导界面,按“Next”,
选择输出数据类型为 Pick Place(如图 2),再依次按“Next”继续,注意文件格式选择 Text(文本)、单位选择 Metric(公制)。然后选择菜单“Tools→ Preference…”,在弹出的 CAM Options 对话框中设定输出坐标文件所在的目录,选择菜单“Tools →Generate CAM Files” 在指定路径下生成坐标文件。
图 2   Protel 输出数据类型选择
2.3 Allegro
Allegro 软件是 Cadence 公司出品的面向中高端企业用户的 PCB 设计软件,主要针对高速、高密度电路板设计,尤其在通讯等领域被广泛应用,目前最新版本号是 16.0。Allegro 软件导出坐标数据步骤:
1) 用 Allegro 软件打开 PCB 设计文件。
2) 设定原点和切换公制单位。选择菜单“Setup → Drawing Size…”,弹出如图 3 所示对话框,用户单位选择 millimeter,MOVE ORIGIN 栏中输入新原点位置相对于当前原点的坐标数据,然后按“OK”确定。
图 3   Allegro 单位切换和原点设定
3) 坐标文件导出。选择菜单“File → Export → Placement…”,弹出如图4 所示对话框,
注意 Placement Origin 选择 Body Center,按“Export”按钮输出坐标数据。